Fatal error message

sipkeg
sipkeg
Offline
0
Hello,
I like to install on local system the demo of Ixion template. Then first this fault message: C:\xampp\htdocs\yoothem\libraries\vendor\joomla\registry\src\Format\Json.php on line 12
is it possible to remove this line?
Responses (9)
  • Accepted Answer

    Saturday, January 28 2017, 05:07 PM - #Permalink
    0
    Hi slpkeg,
    Can you give us more information about environment, please?
    Which Joomla and PHP version are in use?
    • sipkeg
      more than a month ago
      Hi, Eugene,
      The joomla version 3.6.5. PHP version 7.00.15
      regards sip
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, January 28 2017, 09:37 PM - #Permalink
    0
    Check out if the following PHP extensions are installed on your server:

    JSON
    DOM XML
    Multibyte string (mbstring)


    It's necessary extensions that should be on your server.
    The reply is currently minimized Show
  • Accepted Answer

    sipkeg
    sipkeg
    Offline
    Sunday, January 29 2017, 01:46 PM - #Permalink
    0
    Hello Eugene,

    The joomla version of the template demo is 3.4.3 .I found this in administrator/manifests/files/joomla.xml
    It's a know issue. Joomla 3.4 isn't compatible with PHP7 yet.

    regards sipkeg
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, January 29 2017, 02:03 PM - #Permalink
    0
    Hi sipkeg,
    We did not update Joomla in demo package since it means the end user must keep Joomla is up-to-date.
    Please update Joomla to its latest version.

    Cheers.
    The reply is currently minimized Show
  • Accepted Answer

    sipkeg
    sipkeg
    Offline
    Monday, January 30 2017, 10:41 AM - #Permalink
    0
    Hello Eugene,
    As I wrote before the joomla version is 3.6.5 and as far as I know this is the last version of Joomla. The PHP version is 7.00.13

    regards Sipkeg
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 30 2017, 11:32 AM - #Permalink
    0
    Hi sipkeg,

    So... You ran quickstart with Ixion demo where Joomla is outdated, right? Just update Joomla to its latest version and the problem should be solved.

    Updating from an existing version
    The reply is currently minimized Show
  • Accepted Answer

    sipkeg
    sipkeg
    Offline
    Monday, January 30 2017, 01:57 PM - #Permalink
    0
    Hello Eugene,

    For good understanding. I have a local server with Xampp and his PHP version is 7.00.13. Than I want to install the demo version of Ixion template.
    The first thing that happens is the faultmessage and installation stops. Because the joomla version is a part of the demo, how can I change it?
    Or should I first do a default installation of joomla 3.6.5 and then the installation with the quick start?
    I am now a bit confused.

    regards sipkeg
    The reply is currently minimized Show
  • Accepted Answer

    sipkeg
    sipkeg
    Offline
    Tuesday, January 31 2017, 10:39 AM - #Permalink
    0
    Hello Eugene,

    Because the demopackage is still joomla 3.4.3, I have installed an older version of Xampp with PHP 5.x
    Now I can to test the template
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 31 2017, 12:11 PM - #Permalink
    0
    Hi sipkeg,
    Now it's clear.
    You need to switch PHP on earlier version (e.g. 5.6) to get ability to launch and update Joomla on the site. As soon as it will be done, it's time to enable PHP 7 again.
    It is better to use another environment (software or hosting) or install Xampp with PHP 5.6 support (what you finally have done).

    We'll update the quickstart package soon.

    Good luck with Ixion!
    The reply is currently minimized Show
Your Reply